It is currently Sat Sep 21, 2019 8:02 am

All times are UTC - 5 hours [ DST ]




Post new topic Reply to topic  [ 2 posts ] 
Author Message
 Post subject: Set Trigger Help Needed
PostPosted: Mon Jul 20, 2009 6:45 pm 
Offline
Corporal
User avatar

Joined: Thu May 07, 2009 7:38 am
Posts: 96
Following an event this past weekend, I thoroughly cleaned my double trigger Sharps. I then decided to do something I had not done in the year or so that I've owned it. I decided to pull the side plate and oil the lock mechanisms. Unfortunately, I also decided to pull the hammer to make sure there was no rust behind it (as commonly happens with my P-53 Enfield).

The hammer came off very reluctantly, but the sideplate itself came right off. No rust/powder in the lock mechanism or behind the hammer. I oiled everything up nicely and reassembled. Now when the set trigger is used, the hammer only falls to the half cock position when the main trigger is pulled. If only the main trigger is pulled, everything functions fine. Note that during the disassembly/oiling process, the set trigger adjustment screws were not touched. I have futzed with them and set them per the instructions in the manual. Same results.

I suspect that I'll end up having to take it to a shop once the season is over though, as I've tried about everything I could think of. But any suggestions will be gratefully received!

Thanks,
Calum

_________________
Calum Munro

40th PVI, 11th Reserves, Co F
http://www.facebook.com/reserve.companyf

1st USSS, Co H
http://nyberdans.wix.com/nyberdans


Top
 Profile  
 
PostPosted: Sat Jul 25, 2009 12:18 am 
Offline
Corporal
User avatar

Joined: Thu May 07, 2009 7:38 am
Posts: 96
Okay, I don't have any clue at all what this has to do with anything, but the Sharps is back up and running. I hadn't gotten the hammer quite tight against the lock plate, so I put it in the vice this morning (leather on both sides to protect things, naturally) and tightened it down. Don't think I got it quite as far as it initially was, but the hammer's hitting the cone squarely again.

But the set trigger's now working. :D Tried it a couple times by hand, and then 'fired" it half a dozen times with leather to protect the cone. She's working fine. And I don't have the faintest clue what any of it had to do with anything, unless
something realligned in the actual lock that I jarred out of place when I pulled the hammer. But visually there is no difference, so I'm completely baffled. :shock:

This was literally hours before I was going to take it to a local gunsmith - it was bugging me, so I decided not to wait for season's end.

Calum

_________________
Calum Munro

40th PVI, 11th Reserves, Co F
http://www.facebook.com/reserve.companyf

1st USSS, Co H
http://nyberdans.wix.com/nyberdans


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 2 posts ] 

All times are UTC - 5 hours [ DST ]


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
Powered by phpBB® Forum Software © phpBB Group